修改MAC系统下默认PHP版本

今天在使用mac时遇到了一个问题,因为需要composer拉取laravel5.6,但是提示我php版本过低,但是我本人使用的是集成环境MAMP,已经切换了php7.2的版本,这个为什么没有生效呢?经检查是因为composer检测得是mac下环境变量生效的php版本

$ which php
/usr/local/bin

思路

开始我是想把mac自带的环境卸载掉,在网上搜索一通,都是一样的,什么左侧目录右侧删除,但是到我这就删除不了了,在root用户下面删除,提示我没有权限,我了个乖乖,又去百度root用户删除不了文件,然后说什么flags问题,然后我就按照去除flags

#去除flags Mac [sudo] chflags nouchg filename

然后在执行rm -rf 还是一样的结果

php: Operation not permitted

gg,此路不同,谁研究好了麻烦告知下

更改环境变量来修改默认的php版本

新建一个.bas_profile文件并编辑

vim ~/.bash_profile

然后在里面输入自己想要的php版本

export PATH=/Applications/MAMP/bin/php/php7.2.7/bin:$PATH #/Applications/MAMP/bin/php/php7.2.7/bin是我的php版本路径

保存重载环境变量

source ~/.bash_profile

运行which php查看php默认版本,搞定

关于mac修改默认php的方法就分享到这里了,希望以上内容可以对大家有一定的帮助,可以学到更多知识。如果觉得文章不错,可以把它分享出去让更多的人看到。