出现身份验证错误。

要求的函数不受支持

 

这可能是由于 CredSSP 加密数据库修正。

 

多次重试,问题依旧,而以往是可以正常进行远程桌面连接的。

 

原因:

系统更新。微软系统补丁的更新将 CredSSP 身份验证协议的默认设置进行了调整,由“易受攻击”,修改为“已缓解”,从而导致远程桌面连接失败。

 

解决办法:

方法一. 修改组策略

1. win+R打开运行对话框,运行本地组策略编辑器:gpedit.msc

 

2. 在本地组策略编辑器中,依次选择:计算机配置>管理模板>系统>凭据分配>加密数据库修正。

 

3. 双击“加密数据库修正”选项打开加密数据库修正编辑窗口,选择“已启用”,并将保护级别修改为“易受攻击”,保存修改即可。

 

方法二. 修改注册表

win10家庭版不支持gpedit.msc命令,可以通过修改注册表来解决。

1. win+R打开运行对话框,运行注册表编辑器:regedit。

2. 依次打开:HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\System\CredSSP\Parameters

如果System目录没有子文件,则右击System,新建:CredSSP,然后右击CredSSP,新建:Parameters。

然后右击Parameters,新建:DWORD(32)位,命名为:AllowEncryptionOracle。

3. 双击AllowEncryptionOracle,数值数据修改为2,重新尝试远程桌面连接,仍然失败则重启电脑重试。

文章知识点与官方知识档案匹配,可进一步学习相关知识

点赞(0) 打赏

评论列表 共有 0 条评论

暂无评论

微信小程序

微信扫一扫体验

立即
投稿

微信公众账号

微信扫一扫加关注

发表
评论
返回
顶部